DPRG
DPRG List  



[DPRG] Roombacomm project

Subject: [DPRG] Roombacomm project
From: Paul Bouchier bouchier at classicnet.net
Date: Thu Jul 30 23:11:03 CDT 2009

DPRG folks - I'd like to thank Steve Rainwater for setting up a nice project
page and setting up the SVN repository for the roombacomm code from the book
"Hacking Roomba" by Tod Kurt. Check out the project page, linked from the
news section, and at the top of the "projects" page. There's a link to Tod's
book there too. Club member Jonathan Pitts & I have taken on maintenance of
the roombacomm code.

I also want to welcome our newest club member, Tod Kurt, author of "Hacking
Roomba". We have a number of published authors in the club, and it's a
pleasure to add to that esteemed group an author as famous as Tod. Tod
kindly consented to moving the roombacomm source into the DPRG repository,
where it can be more widely available and where community maintenance is
possible.

I want to encourage folks with technical questions about hacking Roombas to
submit them on the Robotic Hacking forum at www.robotreviews.com under the
Robot Chat tab. There's a strong group of Roomba support folks there who try
hard to help people out.

Thanks

Paul Bouchier
DPRG Secretary

> Message: 2
> Date: Wed, 29 Jul 2009 19:24:12 -0700 (PDT)
> From: Bernie Doehner <foxmoy at yahoo.com>
> Subject: [DPRG] RoombaComm 0.96 Setup with FireFly BlueTooth and 535
> To: dprglist at dprg.org
> Message-ID: <508206.26571.qm at web112603.mail.gq1.yahoo.com>
> Content-Type: text/plain; charset=us-ascii
> 
> 
> Hello,
> 
> I am new to hacking the roomba, and just installed DPRG's 
> roombacomm 0.96 and am attempting to use it with my Firefly 
> bluetooth and 535.
> 
> I did change the baud rate to 115k2.
> 
> However, when I run RoombaCommTest,
> the buttons seem to be mismatched.
> 
> Reset, and any of the arrows just make it follow the normal algorithm.
> 
> I have selected Roomba 5xx (OI). Any of the command line mode 
> java programs similarly don't make it go in the proper 
> direction (like DriveRealTime)
> 
> I am wondering if it's maybe set to non 5xx commands?
> 
> Any suggestions on where to start debugging this? Are there 
> configuration things I should check?
> 
> Thanks,
> Bernie


More information about the DPRG mailing list